您現在的位置:程序化交易>> 期貨公式>> 博易大師>> 博易大師知識>>正文內容

請問下面的怎么編成公式?請幫忙,十分感謝 [博易POBO]

咨詢內容:

請問下面的怎么編成公式?請幫忙,十分感謝

多頭
1.上分形定義:一個K線創出最近5天內的最高價,同時k線的最高價和最低價比昨天K線的都高,同時后一天K線的最高價和最低價比這個K線都低。
2。趨勢定義:參考K線收盤價高于上分形的最高價,次天最高價和收盤價比參考K線都高,此時變為紅色。
3.回調:當前K線創出最近5天的最低點,變灰.直到(如2趨勢定義),重新變為紅色.
空頭
4.下分形定義:一個k線創出最近5天內的最低點,同時K線的最高價和最低價比昨天K線的都低,同時后一天K線的最高價和最低價比這個K線都高。
5。趨勢定義:參考K線收盤價低于上分形的最低價,次天最高價和收盤價比參考K線都低,此時變為綠色。
6.回調:當前K線創出最近5天的最高點,變灰.直到(如5趨勢定義),重新變為綠色.

公式很復雜,望高手幫忙編一下,十分感激。

? QQ截圖20170523111328.png<!-- 咨詢內容:

附件 :

-->

?

?來源:程序化99網( www.myblss.tw )

博易技術人員: A1:=H>REF(H,1) AND L>REF(L,1) AND H>REFX(H,1) AND L>REFX(L,1) ?;
A2:=H>=HHV(H,5);
A3:=L<=LLV(L,5);
A4:=H<REF(H,1) AND L<REF(L,1) AND H>REFX(H,1) AND L>REFX(L,1);
B1:=H<REF(H,1) AND L<REF(L,1) AND H<REFX(H,1) AND L<REFX(L,1);
B2:=H>REF(H,1) AND L>REF(L,1) AND H<REFX(H,1) AND L<REFX(L,1);
STICKLINE(A1=1 AND A2=1,O,C,10,10),COLORORANGE;
STICKLINE(A3=1 AND A4=1,O,C,10,10),COLORGRAY;
STICKLINE(B1=1 AND A3=1,O,C,10,10),COLORGREEN;
STICKLINE(B2=1 AND A2=1,O,C,10,10),COLORGRAY; 您好,可以右鍵點擊這個公式點擊修改公式復制修改一下。 來源 程序化久久網

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  點擊這里給我發消息或微信:cxhjy888 進行 有償 編寫!不貴!點擊查看價格!


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
新疆18选7基本走势带坐标