您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

趨勢五指副圖指標公式源碼[通達信公式]

相關標簽:

?

?

原理解析:


?

?來源:程序化99( www.myblss.tw )

源碼:

?

?

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趨勢:=EMA(VAR3,3)-10;
大莊建倉區:0,LINETHICK1,COLORCC9900;
VAR4:=(趨勢-REF(趨勢,1))/REF(趨勢,1)*100;
STICKLINE(趨勢<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趨勢<=13,15),25,'準備數錢'),COLORCC9900;
STICKLINE(趨勢<=13 AND VAR4>13,0,50,5,0),COLOR0099FF;
VAR5:=FILTER((趨勢<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'明天買進'),COLOR0099FF;
STICKLINE(趨勢>=90 AND VAR4,0,30,5,0),COLORGRAY;
VAR6:=FILTER((趨勢>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'清倉'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
DRAWICON(CROSS(90,VAR9),95,2);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
五指山:EMA(IF(LOW<=VAR7 AND 趨勢<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(五指山>0,0 ,五指山*1.2,8,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趨勢線: 趨勢,COLORFF0000;
VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
分水嶺:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17<REF(VAR17,1),0,VAR17,1,0),COLOR00FF00;
VAR18:=MA(趨勢線,8);
DRAWTEXT(CROSS(趨勢線,VAR2)AND 趨勢線>REF(趨勢線,1)AND 趨勢線<50,50,'全倉買進'),COLORYELLOW;
DRAWTEXT_FIX(C>O,0.01,0.9,0,' www.myblss.tw '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

?

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  有需要幫忙請點擊這里留言!!!或微信:cxhjy888 進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  新疆18选7基本走势带坐标