您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

纏論中樞主圖指標公式 操盤公式[大智慧公式]

相關標簽:纏論中樞主圖指標公式 、 頂底分型主圖指標公式 、 海龜交易主圖指標公式 、 主圖壓力支撐指標公式 、 底部引爆主圖指標公式 、 神奇組合主圖指標公式 、 股票陰陽主圖指標公式 、 黃金分割主圖指標公式 、 文華期貨主圖指標公式 、 巴菲特主圖指標公式 、 最神奇的主圖買賣指標 、 博易大師主圖指標公式 、

?

精品主圖

?

原理解析:


?

?來源:程序化99( www.myblss.tw )

源碼:

?

?


操盤線:EMA(CLOSE,13),COLORRED;
M5:MA(CLOSE,5),COLORWHITE;
黃金線:COST(24),COLORYELLOW,POINTDOT,LINETHICK4;
底線:COST(5),COLORGREEN;
1號線:MA(CLOSE,144),COLORWHITE,LINETHICK2;
4號線:EMA(CLOSE,453),COLORRED,LINETHICK2;
VAR2:=(HIGH+LOW+CLOSE*2)/4;
VAR3:=EMA(VAR2,21);
VAR4:=STD(VAR2,21);
VAR5:=((VAR2-VAR3)/VAR4*100+200)/4;
VAR6:=(EMA(VAR5,5)-25)*1.56;
AK:=EMA(VAR6,2)*1.22;
AD:=EMA(AK,2);
AJ:=3*AK-2*AD;
STICKLINE(CROSS(AK,AD),LOW,LOW-0.09,8,0),COLORRED;{短線買}
AC:=CLOSE;
AH:=HIGH;
AL:=LOW;
AO:=OPEN;
STICKLINE(AC>=AO,AH,AC,1,0),color008899;
STICKLINE(AC>=AO,AH,AC,0,0),color77ffee;
STICKLINE(AC>=AO,AO,AL,1,0),color008899;
STICKLINE(AC>=AO,AO,AL,0,0),color77ffee;
STICKLINE(AC>AO,AC,AO,8,0),COLOR008899;
STICKLINE(AC>AO,AC,AO,7,0),COLOR1199aa;
STICKLINE(AC>AO,AC,AO,6,0),COLOR22aabb;
STICKLINE(AC>AO,AC,AO,5,0),COLOR33bbcc;
STICKLINE(AC>AO,AC,AO,4,0),COLOR44ccdd;
STICKLINE(AC>AO,AC,AO,3,0),COLOR55ddee;
STICKLINE(AC>AO,AC,AO,2,0),COLOR66eeee;
STICKLINE(AC>AO,AC,AO,1,0),COLOR77ffee;
STICKLINE(AC<=AO,AH,AC,1,0),colorff8800;
STICKLINE(AC<=AO,AH,AC,0,0),colorffff33;
STICKLINE(AC<=AO,AO,AL,1,0),colorff8800;
STICKLINE(AC<=AO,AO,AL,0,0),colorffff33;
STICKLINE(AC<=AO,AC,AO,8,0),COLORff8800;
STICKLINE(AC<=AO,AC,AO,7,0),COLORff9900;
STICKLINE(AC<=AO,AC,AO,6,0),COLORffaa11;
STICKLINE(AC<=AO,AC,AO,5,0),COLORffbb11;
STICKLINE(AC<=AO,AC,AO,4,0),COLORffcc22;
STICKLINE(AC<=AO,AC,AO,3,0),COLORffdd22;
STICKLINE(AC<=AO,AC,AO,2,0),COLORffee33;
STICKLINE(AC<=AO,AC,AO,1,0),COLORffff33;
F:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
今小昨:=IF(CLOSE<REF(OPEN,1) AND f<0,1,0);
p1:=今小昨;
今小前:=IF(CLOSE<REF(OPEN,2) AND f<0,1,0);
p2:=今小前;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,4,0),COLORRED;{短線進}
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,OPEN,CLOSE,4,0),COLORBLUE;{短線出}
YC:=REF(CLOSE,1);
止損價位:(YC*1.0035*97+0.2)/99.65,COLORRED,LINETHICK0; { }
DRAWTEXTABS(CLOSE,0,' ======================'),COLORRED;DRAWTEXTABS(CLOSE,160,'盤 ----------------------'),COLORRED;
DRAWTEXTABS(CLOSE,240,'鐵 ----------------------'),COLORRED;
DRAWTEXTABS(CLOSE,320,'律 ======================'),COLORRED;DRAWTEXTABS(CLOSE,120,' 買入時間 2:30以后' ),colorYellow;
DRAWTEXTABS(CLOSE,200,' 止損價位 '+NUMTOSTR(止損價位)+'元'),colorYellow;
DRAWTEXTABS(CLOSE,280,' 線上:工作 線下:休息'),color00FFFF;
{ }
gj:=AMOUNT/VOL/100;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW;
明日支撐:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反轉:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撐:=REF(明日支撐 , 1);
DRAWTEXTABS(200,8,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,22,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,36,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,52,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,70,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,86,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,102,'-----------------'),ColorFFFFFF;
DRAWTEXTABS(200,14,'今日阻力=:'+NUMTOSTR(今日阻力)+''),Color00FFFF;
DRAWTEXTABS(200,30,'今日支撐=:'+NUMTOSTR(今日支撐)+''),Color00FF00;
DRAWTEXTABS(200,46,'明日突破=:'+NUMTOSTR(明日突破)),ColorFF00FF;
DRAWTEXTABS(200,62,'明日阻力=:'+NUMTOSTR(明日阻力)),ColorFFFF00;
DRAWTEXTABS(200,78,'明日支撐=:'+NUMTOSTR(明日支撐)),COLORRED;
DRAWTEXTABS(200,94,'明日反轉=:'+NUMTOSTR(明日反轉)),COLORGREEN;
N:=13;
A:=HHV(HIGH,N)=HIGH AND HIGH>REF(HIGH,1);A1:=FILTER(A,N-1);
B:=LLV(LOW,N)=LOW AND LOW<REF(LOW,1);B1:=FILTER(B,N-1);
TS1:=BARSLAST(A1);
箱頂:REF(HIGH,TS1) ,COLORFF00FF, LINETHICK0;
STICKLINE(1,箱頂,箱頂,7,0),COLORFF00FF;
TS11:=BARSLAST(B1);
箱底:REF(LOW,TS11) ,COLORFF8080, LINETHICK0;
STICKLINE(1,箱底,箱底,7,0),COLORFF8080;
DRAWICON(CROSS(CLOSE,箱頂),HIGH*1.01,4);
DRAWICON(CROSS(箱底,CLOSE),LOW*0.99,5);
DRAWICON(CROSS(箱頂,CLOSE) AND REF(CLOSE,1)>=箱頂,箱頂,12);

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  有需要幫忙請點擊這里留言!!!或微信:cxhjy888 進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  新疆18选7基本走势带坐标