您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

持股線穩贏10% 大智慧通達信通用公式源碼[大智慧公式]

相關標簽:

?

頂極買賣

?

?

原理解析:


?

?來源:程序化99( www.myblss.tw )

源碼:

?

?


{持股線:=EMA(C,26);
PARTLINE(持股線,CLOSE>持股線,RGB(255,0,0),CLOSE<持股線,RGB(0,255,0),1,RGB(0,0,255)),LINETHICK2;}{去除花括號 大智慧2 可用}

A1:= 3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
A2:= (EMA(A1,5)-REF(EMA(A1,5),1))/REF(EMA(A1,5),1)*100;
A3:= (C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100;
趨勢線:= MA(3*SMA(A3,6,1)-2*SMA(SMA(A3,5,1),5,1),2);
VAR8:= LLV(L,5)=LLV(L,45) AND C>=O*1.04;
VAR9:= C>(REF(H,1)+REF(L,1))/2;
VAR10:= VAR8 AND VAR9;
VAR14:= LLV(L,1)=LLV(L,35) AND C>=O*1.04;
VAR17:= ((C-MA(C,6))/MA(C,6)*100+(C-MA(C,24))/MA(C,24)*100+(C-MA(C,32))/MA(C,32)*100)/3;
VAR27:= MA(HHV(HIGH,485),17);
VAR28:= MA(HHV(HIGH,222),17);
VAR29:= MA(HHV(HIGH,96),17);
VAR30:= MA(LLV(LOW,485),17);
VAR31:= MA(LLV(LOW,222),17);
VAR32:= MA(LLV(LOW,96),17);
VAR33:= MA((VAR30*0.96+VAR31*0.96+VAR32*0.96+VAR27*0.558+VAR28*0.558+VAR29*0.558)/6,17);
VAR34:= MA((VAR30*1.25+VAR31*1.23+VAR32*1.2+VAR27*0.55+VAR28*0.55+VAR29*0.65)/6,17);
VAR35:= MA((VAR30*1.3+VAR31*1.3+VAR32*1.3+VAR27*0.68+VAR28*0.68+VAR29*0.68)/6,17);
VAR36:= LLV(LOW,30);
VAR37:= MA((VAR33*3+VAR34*2+VAR35)/6*1.738,17);
VAR38:= VAR37;
VAR39:= LOW;
VAR40:= REF(LOW,1);
VAR41:= SMA(ABS(VAR39-VAR40),3,1)/SMA(MAX(VAR39-VAR40,0),3,1)*100;
VAR42:= MA(IF(CLOSE*1.35<=VAR38,VAR41*10,VAR41/10),3);
VAR43:= HHV(VAR42,30);
VAR73:= (CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR75:= SMA(VAR73,3,1);
絕佳買點:= MA(IF(LOW<=VAR36,(VAR42+VAR43*2)/2,0),3);
跑:= FILTER(REF(EMA(A1,5),1)>90 AND A2<0 ,7);
買線:= EMA(CLOSE,2);
賣線:= EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
龍:= VAR10;
AA1:= AMOUNT/VOL;
BB1:= LOW<AA1*0.9;
CC1:= (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
DD1:= LOW<MA(CLOSE,5)*0.921;
EE1:= VOL<MA(VOL,5)*1.5;
FF1:= BB1 AND CC1 AND DD1 AND EE1;
二十天最低跌幅:= HHV(CLOSE,20)/LLV(CLOSE,20);
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:= SMA(RSV,3,1);
D:= SMA(K,3,1);
J:= 3*K-2*D;
X:= LLV(J,2)=LLV(J,8);
長期底部:= LLV(HIGH,30);
上:= SMA(LOW,5,2)*0.96;
短期底部:= LLV(HIGH,30)*0.93;
LC:= REF(CLOSE,1);
RSI:= SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
大頂:= FILTER(VAR17>20 AND FILTER(VAR17<REF(VAR17,1),5),5);
VAR76:= (OPEN+LOW+HIGH+CLOSE)/4;
短底2:= EMA(VAR76,5);
支撐:= HHV(短底2,60);
VAR77:= (HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR78:= SMA(VAR77,5,1);
VAR79:= SMA(VAR78,8,1);
VAR80:= CROSS(VAR78,VAR79) AND VAR79<5;
VAR81:= CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR80;
VAR82:= IF(CLOSE>1000,VAR80,VAR81);
VAR93:= 100-3*SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+2*SMA(SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR94:= 100-3*SMA((O-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+2*SMA(SMA((O-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR95:= VAR93REF(V,1) AND C>REF(C,1);
大資金入場:=VAR95 AND COUNT(VAR95,30)=1;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.095,'大資金'),COLORYELLOW;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.06,'進場'),COLORYELLOW;
逃:= FILTER(HIGH>支撐 AND CLOSE<支撐 AND CLOSE/OPEN>0-1.06 AND CLOSE<OPEN,5);
選逃:= FILTER(VAR82>0 OR 逃 OR CROSS(84,RSI) OR 大頂,3);
賣:= CROSS(賣線,買線);
散戶:= SMA(VAR75,3,1);
新莊:= SMA(散戶,3,1);
買:= CROSS(買線,賣線);
大黑馬:= CROSS(趨勢線,0) AND EMA(A1,5)<40;
大買:= FILTER(絕佳買點>30000,5);
買1:= CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND 二十天最低跌幅>=1.3;
買2:= FILTER(FF1,3);
買3:= VAR14;
選底:= FILTER(LOW<=上 AND HIGH>=短期底部 AND CLOSE>=長期底部 AND CLOSE/OPEN>1.03,3);
選買:= FILTER(買2 OR 選底,3) AND COUNT(買1+買3+龍,3)>0 ;
STICKLINE(選買,C,HHV(H,10)*0.94,0.3,0),ColorFB2DFB;
DRAWTEXT(選買,HHV(HIGH,10)*1,'穩賺 '),ColorFB2DFB;
DRAWTEXT(選買,HHV(HIGH,10)*0.97,'10%'),ColorFB2DFB;
DRAWTEXT(買,L,'買'),COLOR0000FF;
DRAWTEXT(大黑馬,LOW*0.98,'大黑馬'),COLORFFFFFF;
DRAWTEXT(大買,L*0.98,'大買'),COLOR0000FF;
DRAWTEXT(IF(選底,100,0),LOW*0.995,'底'),COLOR399C71;
DRAWTEXT(賣,H,'賣'),COLOR00FFFF;
DRAWTEXT(選逃,HIGH*1.04,'逃'),COLOR00FFFF;
DRAWTEXT(跑,H*1.02,'跑'),COLOR00FFFF;
DRAWTEXT(CROSS(新莊,散戶) AND 新莊>75,HIGH*1.04,'拋'),COLOR00FFFF;


?

?

?



同花順



A1:= 3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
A2:= (EMA(A1,5)-REF(EMA(A1,5),1))/REF(EMA(A1,5),1)*100;
A3:= (C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100;
趨勢線:= MA(3*SMA(A3,6,1)-2*SMA(SMA(A3,5,1),5,1),2);
VAR8:= LLV(L,5)=LLV(L,45) AND C>=O*1.04;
VAR9:= C>(REF(H,1)+REF(L,1))/2;
VAR10:= VAR8 AND VAR9;
VAR14:= LLV(L,1)=LLV(L,35) AND C>=O*1.04;
VAR17:= ((C-MA(C,6))/MA(C,6)*100+(C-MA(C,24))/MA(C,24)*100+(C-MA(C,32))/MA(C,32)*100)/3;
VAR27:= MA(HHV(HIGH,485),17);
VAR28:= MA(HHV(HIGH,222),17);
VAR29:= MA(HHV(HIGH,96),17);
VAR30:= MA(LLV(LOW,485),17);
VAR31:= MA(LLV(LOW,222),17);
VAR32:= MA(LLV(LOW,96),17);
VAR33:= MA((VAR30*0.96+VAR31*0.96+VAR32*0.96+VAR27*0.558+VAR28*0.558+VAR29*0.558)/6,17);
VAR34:= MA((VAR30*1.25+VAR31*1.23+VAR32*1.2+VAR27*0.55+VAR28*0.55+VAR29*0.65)/6,17);
VAR35:= MA((VAR30*1.3+VAR31*1.3+VAR32*1.3+VAR27*0.68+VAR28*0.68+VAR29*0.68)/6,17);
VAR36:= LLV(LOW,30);
VAR37:= MA((VAR33*3+VAR34*2+VAR35)/6*1.738,17);
VAR38:= VAR37;
VAR39:= LOW;
VAR40:= REF(LOW,1);
VAR41:= SMA(ABS(VAR39-VAR40),3,1)/SMA(MAX(VAR39-VAR40,0),3,1)*100;
VAR42:= MA(IF(CLOSE*1.35<=VAR38,VAR41*10,VAR41/10),3);
VAR43:= HHV(VAR42,30);
VAR73:= (CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR75:= SMA(VAR73,3,1);
絕佳買點:= MA(IF(LOW<=VAR36,(VAR42+VAR43*2)/2,0),3);
跑:= FILTER(REF(EMA(A1,5),1)>90 AND A2<0 ,7);
買線:= EMA(CLOSE,2);
賣線:= EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
龍:= VAR10;
AA1:= AMOUNT/VOL;
BB1:= LOW<AA1*0.9;
CC1:= (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
DD1:= LOW<MA(CLOSE,5)*0.921;
EE1:= VOL<MA(VOL,5)*1.5;
FF1:= BB1 AND CC1 AND DD1 AND EE1;
二十天最低跌幅:= HHV(CLOSE,20)/LLV(CLOSE,20);
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:= SMA(RSV,3,1);
D:= SMA(K,3,1);
J:= 3*K-2*D;
X:= LLV(J,2)=LLV(J,8);
長期底部:= LLV(HIGH,30);
上:= SMA(LOW,5,2)*0.96;
短期底部:= LLV(HIGH,30)*0.93;
LC:= REF(CLOSE,1);
RSI:= SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
大頂:= FILTER(VAR17>20 AND FILTER(VAR17<REF(VAR17,1),5),5);
VAR76:= (OPEN+LOW+HIGH+CLOSE)/4;
短底2:= EMA(VAR76,5);
支撐:= HHV(短底2,60);
VAR77:= (HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR78:= SMA(VAR77,5,1);
VAR79:= SMA(VAR78,8,1);
VAR80:= CROSS(VAR78,VAR79) AND VAR79<5;
VAR81:= CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR80;
VAR82:= IF(CLOSE>1000,VAR80,VAR81);
VAR93:= 100-3*SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+2*SMA(SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR94:= 100-3*SMA((O-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+2*SMA(SMA((O-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR95:= VAR93REF(V,1) AND C>REF(C,1);
大資金入場:=VAR95 AND COUNT(VAR95,30)=1;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.095,'大資金'),coloryellow;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.06,'進場'),coloryellow;
逃:= FILTER(HIGH>支撐 AND CLOSE<支撐 AND CLOSE/OPEN>0-1.06 AND CLOSE<OPEN,5);
選逃:= FILTER(VAR82>0 OR 逃 OR CROSS(84,RSI) OR 大頂,3);
賣8:=CROSS(賣線,買線);
散戶:= SMA(VAR75,3,1);
新莊:= SMA(散戶,3,1);
買8:= CROSS(買線,賣線);
大黑馬:= CROSS(趨勢線,0) AND EMA(A1,5)<40;
大買:= FILTER(絕佳買點>30000,5);
買1:= CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND 二十天最低跌幅>=1.3;
買2:= FILTER(FF1,3);
買3:= VAR14;
選底:= FILTER(LOW<=上 AND HIGH>=短期底部 AND CLOSE>=長期底部 AND CLOSE/OPEN>1.03,3);
選買:= FILTER(買2 OR 選底,3) AND COUNT(買1+買3+龍,3)>0 ;
STICKLINE(選買,C,HHV(H,10)*0.94,0.3,0),COLORFF0000;
DRAWTEXT(選買,HHV(HIGH,10)*1,'穩賺 '),COLORFF0000;
DRAWTEXT(選買,HHV(HIGH,10)*0.97,'10%'),COLORFF0000;
DRAWTEXT(買8,L,'買'),COLOR0000FF;
DRAWTEXT(大黑馬,LOW*0.98,'大黑馬'),COLORFFFFFF;
DRAWTEXT(大買,L*0.98,'大買'),COLOR0000FF;
DRAWTEXT(IF(選底,100,0),LOW*0.995,'底'),COLOR399C71;
DRAWTEXT(賣8,H,'賣'),COLOR00FFFF;
DRAWTEXT(選逃,HIGH*1.04,'逃'),COLOR00FFFF;
DRAWTEXT(跑,H*1.02,'跑'),COLOR00FFFF;
DRAWTEXT(CROSS(新莊,散戶) AND 新莊>75,HIGH*1.04,'拋'),COLOR00FFFF;
神奇線:MA(c,19),ColorYELLOW,LINETHICK2;公式僅僅提供源碼,并無公式提供下載

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  有需要幫忙請點擊這里留言!!!或微信:cxhjy888 進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  新疆18选7基本走势带坐标