您現在的位置:程序化交易>> 期貨公式>> 文華財經>> 文華財經知識>>正文內容

[求助]三角形主圖畫線 [文華財經]

  • 咨詢內容: ?

    1、找到最近的高點,該天的最高價高于前一天和后一天的最高價;找到第二近的高點,該天的最高價高于前一天和后一天的最高價,且高于最近高點的最高價;
    2、在這兩天的最高價之間劃條向右延伸的連線;
    3、如果有最近的高點,與原最近高點滿足條件1,去除原有劃線,重新劃一條新的直線;
    于是乎想到干脆取這條下降趨勢線開始后的最低點,但這個低點同樣要是最低價小于前一天最低價和最低價小于后一天最低價和最近一個符合最低價小于前一天最低價和最低價小于后一天最低價再加上一條連線,形成一個整理三角形或者叫 **三角形的畫線趨勢主圖,獻給喜歡研究趨勢的同學。



    {整理三角形主圖畫線}
    T:=BARSLAST(CROSS((H>REF(H,1) AND H>REFX(H,1)),0.5));
    A:=IF(T=0,H,DRAWNULL);
    HH:=ALIGNRIGHT(A);
    H1:=CONST(HH);
    GD:=BARSLAST(CROSS(A>H1,0.5));
    DT:=BARSLAST(A=H1);
    T1:=BARSLAST(CROSS((L<REF(L,1) AND L<REFX(L,1)),0.5));
    LT:=BARSLAST(L=LLV(L,GD+1) AND T1=0);
    LL:=CONST(REF(L,T1));
    LT1:=BARSLAST(L=LL);
    DRAWLINE(CURRBARSCOUNT=CONST(GD)+1,A,CURRBARSCOUNT=CONST(DT)+1,H1,1),COLORYELLOW;
    DRAWLINE(CURRBARSCOUNT=CONST(LT)+1,L,CURRBARSCOUNT=CONST(LT1)+1,L,1),COLORYELLOW;

    ?

    ?

    ?

    ?

    ?

    ?

    ?來源:程序化99

  • 文華技術人員: 文華版本如下
    T:=BARSLAST(CROSS((H>REF(H,1) AND H>REFX(H,1)),0.5)); A:=IF(T=0,H,0); HH:=VALUEWHEN(T=0,H); H1:=REFX1(HH,10000); GD:=BARSLAST(CROSS(A>H1,0.5)); DT:=BARSLAST(A=H1); T1:=BARSLAST(CROSS((L<REF(L,1) AND L<REFX(L,1)),0.5)); LT:=BARSLAST(L=LLV(L,GD+1) AND T1=0); LL:=REFX1(REF(L,T1),10000); LT1:=BARSLAST(L=LL); CURRBARSCOUNT:=REFX1(BARPOS,10000)-BARPOS+1; DRAWLINE1(CURRBARSCOUNT=REFX1(GD,10000)+1,A,CURRBARSCOUNT=REFX1(DT,10000)+1,H1,1),COLORYELLOW; DRAWLINE1(CURRBARSCOUNT=REFX1(LT,10000)+1,L,CURRBARSCOUNT=REFX1(LT1,10000)+1,L,1),COLORYELLOW;
    ?
    ?

    ?

    ?來源: www.myblss.tw

  • 文華客服: ?

    ?

    A線:=HHV(H,3);
    B線:=LLV(L,4);
    C線:=(A線+B線)/2;
    傳奇私家指標:IF(C線,C線,NULL),COLORYELLOW,LINETHICK3;


    UR:=6;
    LR:=6;
    CURRBARSCOUNT:=DATACOUNT-BARPOS+1;
    TC1:=IF(H=HHV(H,8*UR),H,NULL);
    TC2:=REFX1(BARSLAST(TC1=H),10000)+1;
    UP:=REFX1(IF(TC2=1,H,REF(H,TC2-1)),10000);
    BC1:=IF(L=LLV(L,8*LR),L,NULL);
    BC2:=REFX1(BARSLAST(BC1=L),10000)+1;
    HP:=CURRBARSCOUNT<=TC2 AND H=UP;
    NOD:=(IF(TC2>BC2,TC2,BC2)-IF(TC2>BC2,BC2,TC2));
    LR1:=FORCAST(C,NOD+1);
    NP:=IF(CURRBARSCOUNT<=MAX(BC2,TC2),REFX1(IF(MIN(TC2,BC2)=1,LR1,REF(LR1,MIN(TC2,BC2)-1)),10000),NULL),POINTDOT,COLOR93BDA8;
    LR2:=SLOPE(C,NOD+1);
    LR3:=REFX1(IF(MIN(TC2,BC2)=1,LR2,REF(LR2,MIN(TC2,BC2)-1)),10000);
    FP:NP-LR3*(NOD),POINTDOT,COLOR93BDA8;
    EQU:(NP+FP)/2,POINTDOT,COLOR93BDA8;
    AD:=ABS(NP-FP);
    DBL:=BARSLAST(ISNULL(BC1)=0)+1;
    DBH:=BARSLAST(ISNULL(TC1)=0)+1;
    BSP:=IF(BC2>TC2,DBL,DBH)-1;
    LRL:=IF(NP>FP,FP+AD/NOD*BSP,FP-AD/NOD*BSP);
    AT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND H>LRL,H,LRL);
    AT2:=HHV(AT1-LRL,MAX(BC2,TC2));
    AT3:=REFX1(BARSLAST(AT1-LRL=AT2),10000);
    AT4:=REFX1(IF(AT3=0,H,REF(H,AT3)),10000);
    AT5:=REFX1(IF(AT3=0,AT1-LRL,REF(AT1-LRL,AT3)),10000);
    ATL:=LRL+AT5;
    UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND L<LRL,L,LRL);
    UT2:=HHV(LRL-UT1,MAX(BC2,TC2));
    UT3:=REFX1(BARSLAST(LRL-UT1=UT2),10000);
    UT4:=REFX1(IF(UT3=0,H,REF(H,UT3)),10000);
    UT5:=REFX1(IF(UT3=0,LRL-UT1,REF(LRL-UT1,UT3)),10000);
    UTL:=LRL-UT5;
    RH:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,ATL,REFX1(REF(ATL,MIN(BC2,TC2)-11),10000));
    RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,UTL,REFX1(REF(UTL,MIN(BC2,TC2)-11),10000));

    中軌:IF(NP>FP,IF(LRL<=RH,LRL,NULL),IF(LRL>=RL,LRL,NULL)),COLORGREEN,LINETHICK1,ALIGN2;
    上軌:IF(NP>FP,IF(ATL<=RH,ATL,NULL),IF(ATL>=RL,ATL,NULL)),COLORRED,LINETHICK1,ALIGN2;
    下軌:IF(NP>FP,IF(UTL<=RH,UTL,NULL),IF(UTL>=RL,UTL,NULL)),COLORYELLOW,LINETHICK1,ALIGN2;

    ?

    高:=REF(HHV(H,80),3),COLORWHITE,LINETHICK1;
    低:=REF(LLV(L,80),3),COLORWHITE,LINETHICK1;
    H19:=高-(高-低)*0.191,COLORWHITE;
    H38:=高-(高-低)*0.382,COLORCYAN;
    H中:=高-(高-低)*0.5,COLORGREEN;
    H61:=高-(高-低)*0.618,COLORYELLOW;
    H80:=高-(高-低)*0.809,COLORYELLOW;
    頂點:REFX1(高,10000),COLORWHITE,LINETHICK1;
    %19.8:REFX1(H19,10000),COLORWHITE,LINETHICK1;
    %38.2:REFX1(H38,10000),COLORWHITE,LINETHICK1;
    %50:REFX1(H中,10000),COLORWHITE,LINETHICK1;
    %61.8:REFX1(H61,10000),COLORWHITE,LINETHICK1;
    %80.9:REFX1(H80,10000),COLORWHITE,LINETHICK1;
    低點:REFX1(低,10000),COLORBLUE,LINETHICK1;

    DRAWTEXT(ISLASTBAR,頂點,'',COLORGREEN,DOT,VALIGN1,FONTSIZE20,DOT;
    DRAWTEXT(ISLASTBAR,低點,'',COLORRED,DOT,VALIGN1,FONTSIZE20,DOT;
    G11:=ZIGZAG(C,1,1)>REF(ZIGZAG(C,1,1),1) AND REF(ZIGZAG(C,1,1),1)<=REF(ZIGZAG(C,1,1),2) AND REF(ZIGZAG(C,1,1),2)<=REF(ZIGZAG(C,1,1),3) AND REF(ZIGZAG(C,1,1),3)<=REF(ZIGZAG(C,1,1),4) AND REF(ZIGZAG(C,1,1),4)<=REF(ZIGZAG(C,1,1),5);
    X11:=ZIGZAG(C,1,1)<REF(ZIGZAG(C,1,1),1) AND REF(ZIGZAG(C,1,1),1)>=REF(ZIGZAG(C,1,1),2) AND REF(ZIGZAG(C,1,1),2)>=REF(ZIGZAG(C,1,1),3) AND REF(ZIGZAG(C,1,1),3)>=REF(ZIGZAG(C,1,1),4) AND REF(ZIGZAG(C,1,1),4)>=REF(ZIGZAG(C,1,1),5);
    DRAWTEXT(G11,L,'#39),COLORRED,DOT,VALIGN1,FONTSIZE20;
    DRAWTEXT(X11,H,'#39),COLORGREEN,DOT,VALIGN1,FONTSIZE20;

    DRAWCOLORKLINE(G11>0 AND G11>X11,COLORWHITE,0);
    DRAWCOLORKLINE(X11>0 AND X11>G11,COLORGREEN,0);

    HJZ:=(3*C+H+L+O)/6;
    HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
    HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
    賺錢旅游:FILTER(HJZ3,5),COLORRED,LINETHICK4,NODRAW;
    STICKLINE(賺錢旅游,O,C,3.3,0),COLORRED;
    STICKLINE(賺錢旅游,H,L,0.1,0),COLORYELLOW;
    DRAWTEXT(賺錢旅游,L*0.98,'#39),COLORWHITE,FONTSIZE20;
    XG:=SUMBARS(FILTER(賺錢旅游,2),1);
    STICKLINE(XG,REF(H,XG-1),REF(H,XG-1),10,0),COLORGREEN;
    XG1:=SUMBARS(FILTER(賺錢旅游,2),1);
    STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF;
    CC:=VALUEWHEN(賺錢旅游,C);
    LL:=VALUEWHEN(賺錢旅游,L);
    HH:=VALUEWHEN(賺錢旅游,H);
    CROSS(C,CC),SOUND('#39);
    CROSSDOWN(C,LL),SOUND('';
    CROSS(C,HH),SOUND('#39);
    DRAWTEXT(CROSS(C,HH),HH,'',VALIGN2,FONTSIZE20;
    STICKLINE(賺錢旅游,O,C,3.3,0),COLORRED;
    STICKLINE(賺錢旅游,H,L,0.1,0),COLORYELLOW;
    DRAWTEXT(賺錢旅游,H*0.98,'#39 ),COLORYELLOW;
    STICKLINE(XG,REF(C,XG-1),REF(C,XG-1),10,0),COLORGREEN;
    STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF;
    STICKLINE(XG,REF(O,XG-1),REF(O,XG-1),10,0),COLORAA00FF;
    CROSS(C,CC),SOUND('';
    CROSSDOWN(C,LL),SOUND('';
    黃金柱:=C>REF(C,1) AND REF(C,1) > REF(C,2) AND REF(C,2) > REF(C,3) AND REF(V,3)>REF(C,2) AND REF(V,2)>REF(V,1) AND REF(V,1)>V;
    XX1:=REFX1(黃金柱,3);
    DRAWCOLORKLINE(XX1,COLORRED,0);
    黃金柱1:=C<REF(C,1) AND REF(C,1) < REF(C,2) AND REF(C,2) < REF(C,3) AND REF(V,3)<REF(C,2) AND REF(V,2)<REF(V,1) AND REF(V,1)>V;
    XX2:=REFX1(黃金柱1,3);
    芝麻開門:FILTER(HJZ3,5),COLORRED,LINETHICK4,NODRAW;
    STICKLINE(芝麻開門,O,C,3.3,0),COLORRED;
    STICKLINE(芝麻開門,H,L,0.1,0),COLORYELLOW;
    DRAWTEXT(芝麻開門,L*0.98,'#39),COLORYELLOW,FONTSIZE20;
    STICKLINE(XG,REF(H,XG-1),REF(H,XG-1),10,0),COLORGREEN;
    STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF;
    CROSS(C,CC),SOUND('#39);
    CROSSDOWN(C,LL),SOUND('';
    CROSS(C,HH),SOUND('#39);
    DRAWTEXT(CROSS(C,HH),HH,'#39),VALIGN2,FONTSIZE19;
    STICKLINE(芝麻開門,O,C,3.3,0),COLORYELLOW;
    STICKLINE(芝麻開門,H,L,0.1,0),COLORYELLOW;
    STICKLINE(XG,REF(C,XG-1),REF(C,XG-1),10,0),COLORGREEN;
    STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF;
    STICKLINE(XG,REF(O,XG-1),REF(O,XG-1),10,0),COLORAA00FF;
    CROSS(C,CC),SOUND('';
    CROSSDOWN(C,LL),SOUND('';

    DRAWTEXT(ISLASTBAR,頂點,'#39),COLORWHITE;
    DRAWTEXT(ISLASTBAR,%19.8,'19.8',COLORYELLOW;
    DRAWTEXT(ISLASTBAR,%38.2,'38.2',COLORMAGENTA,LINETHICK2;
    DRAWTEXT(ISLASTBAR,%50,'50',COLORRED;
    DRAWTEXT(ISLASTBAR,%61.8,'61.8',COLORMAGENTA;
    DRAWTEXT(ISLASTBAR,%80.9,'80.9',COLORYELLOW,LINETHICK2;
    DRAWTEXT(ISLASTBAR,低點,'#39),COLORWHITE;

    ?


    T:=BARSLAST(CROSS((H>REF(H,1) AND H>REFX(H,1)),0.5));
    A:=IF(T=0,H,0);
    HH:=VALUEWHEN(T=0,H);
    H1:=REFX1(HH,10000);
    GD:=BARSLAST(CROSS(A>H1,0.5));
    DT:=BARSLAST(A=H1);
    T1:=BARSLAST(CROSS((L<REF(L,1) AND L<REFX(L,1)),0.5));
    LT:=BARSLAST(L=LLV(L,GD+1) AND T1=0);
    LL:=REFX1(REF(L,T1),10000);
    LT1:=BARSLAST(L=LL);
    CURRBARSCOUNT:=REFX1(BARPOS,10000)-BARPOS+1;
    DRAWLINE1(CURRBARSCOUNT=REFX1(GD,10000)+1,A,CURRBARSCOUNT=REFX1(DT,10000)+1,H1,1),COLORYELLOW;
    DRAWLINE1(CURRBARSCOUNT=REFX1(LT,10000)+1,L,CURRBARSCOUNT=REFX1(LT1,10000)+1,L,1),COLORYELLOW;


    ?

    老師 給看看? 主圖
    ?

    ?

  • 網友回復: A線:=HHV(H,3); B線:=LLV(L,4); C線:=(A線+B線)/2; 傳奇私家指標:IF(C線,C線,NULL),COLORYELLOW,LINETHICK3;

    UR:=6; LR:=6; CURRBARSCOUNT:=DATACOUNT-BARPOS+1; TC1:=IF(H=HHV(H,8*UR),H,NULL); TC2:=REFX1(BARSLAST(TC1=H),10000)+1; UP:=REFX1(IF(TC2=1,H,REF(H,TC2-1)),10000); BC1:=IF(L=LLV(L,8*LR),L,NULL); BC2:=REFX1(BARSLAST(BC1=L),10000)+1; HP:=CURRBARSCOUNT<=TC2 AND H=UP; NOD:=(IF(TC2>BC2,TC2,BC2)-IF(TC2>BC2,BC2,TC2)); LR1:=FORCAST(C,NOD+1); NP:=IF(CURRBARSCOUNT<=MAX(BC2,TC2),REFX1(IF(MIN(TC2,BC2)=1,LR1,REF(LR1,MIN(TC2,BC2)-1)),10000),NULL),POINTDOT,COLOR93BDA8; LR2:=SLOPE(C,NOD+1); LR3:=REFX1(IF(MIN(TC2,BC2)=1,LR2,REF(LR2,MIN(TC2,BC2)-1)),10000); FP:NP-LR3*(NOD),POINTDOT,COLOR93BDA8; EQU:(NP+FP)/2,POINTDOT,COLOR93BDA8; AD:=ABS(NP-FP); DBL:=BARSLAST(ISNULL(BC1)=0)+1; DBH:=BARSLAST(ISNULL(TC1)=0)+1; BSP:=IF(BC2>TC2,DBL,DBH)-1; LRL:=IF(NP>FP,FP+AD/NOD*BSP,FP-AD/NOD*BSP); AT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND H>LRL,H,LRL); AT2:=HHV(AT1-LRL,MAX(BC2,TC2)); AT3:=REFX1(BARSLAST(AT1-LRL=AT2),10000); AT4:=REFX1(IF(AT3=0,H,REF(H,AT3)),10000); AT5:=REFX1(IF(AT3=0,AT1-LRL,REF(AT1-LRL,AT3)),10000); ATL:=LRL+AT5; UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND L<LRL,L,LRL); UT2:=HHV(LRL-UT1,MAX(BC2,TC2)); UT3:=REFX1(BARSLAST(LRL-UT1=UT2),10000); UT4:=REFX1(IF(UT3=0,H,REF(H,UT3)),10000); UT5:=REFX1(IF(UT3=0,LRL-UT1,REF(LRL-UT1,UT3)),10000); UTL:=LRL-UT5; RH:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,ATL,REFX1(REF(ATL,MIN(BC2,TC2)-11),10000)); RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,UTL,REFX1(REF(UTL,MIN(BC2,TC2)-11),10000));
    中軌:IF(NP>FP,IF(LRL<=RH,LRL,NULL),IF(LRL>=RL,LRL,NULL)),COLORGREEN,LINETHICK1,ALIGN2; 上軌:IF(NP>FP,IF(ATL<=RH,ATL,NULL),IF(ATL>=RL,ATL,NULL)),COLORRED,LINETHICK1,ALIGN2; 下軌:IF(NP>FP,IF(UTL<=RH,UTL,NULL),IF(UTL>=RL,UTL,NULL)),COLORYELLOW,LINETHICK1,ALIGN2;
    ?
    高:=REF(HHV(H,80),3),COLORWHITE,LINETHICK1; 低:=REF(LLV(L,80),3),COLORWHITE,LINETHICK1; H19:=高-(高-低)*0.191,COLORWHITE; H38:=高-(高-低)*0.382,COLORCYAN; H中:=高-(高-低)*0.5,COLORGREEN; H61:=高-(高-低)*0.618,COLORYELLOW; H80:=高-(高-低)*0.809,COLORYELLOW; 頂點:REFX1(高,10000),COLORWHITE,LINETHICK1; %19.8:REFX1(H19,10000),COLORWHITE,LINETHICK1; %38.2:REFX1(H38,10000),COLORWHITE,LINETHICK1; %50:REFX1(H中,10000),COLORWHITE,LINETHICK1; %61.8:REFX1(H61,10000),COLORWHITE,LINETHICK1; %80.9:REFX1(H80,10000),COLORWHITE,LINETHICK1; 低點:REFX1(低,10000),COLORBLUE,LINETHICK1;
    DRAWTEXT(ISLASTBAR,頂點,'',COLORGREEN,DOT,VALIGN1,FONTSIZE20,DOT; DRAWTEXT(ISLASTBAR,低點,'',COLORRED,DOT,VALIGN1,FONTSIZE20,DOT;? G11:=ZIGZAG(C,1,1)>REF(ZIGZAG(C,1,1),1) AND REF(ZIGZAG(C,1,1),1)<=REF(ZIGZAG(C,1,1),2) AND REF(ZIGZAG(C,1,1),2)<=REF(ZIGZAG(C,1,1),3) AND REF(ZIGZAG(C,1,1),3)<=REF(ZIGZAG(C,1,1),4) AND REF(ZIGZAG(C,1,1),4)<=REF(ZIGZAG(C,1,1),5); X11:=ZIGZAG(C,1,1)<REF(ZIGZAG(C,1,1),1) AND REF(ZIGZAG(C,1,1),1)>=REF(ZIGZAG(C,1,1),2) AND REF(ZIGZAG(C,1,1),2)>=REF(ZIGZAG(C,1,1),3) AND REF(ZIGZAG(C,1,1),3)>=REF(ZIGZAG(C,1,1),4) AND REF(ZIGZAG(C,1,1),4)>=REF(ZIGZAG(C,1,1),5); DRAWTEXT(G11,L,'#39),COLORRED,DOT,VALIGN1,FONTSIZE20;? DRAWTEXT(X11,H,'#39),COLORGREEN,DOT,VALIGN1,FONTSIZE20;
    DRAWCOLORKLINE(G11>0 AND G11>X11,COLORWHITE,0); DRAWCOLORKLINE(X11>0 AND X11>G11,COLORGREEN,0);
    HJZ:=(3*C+H+L+O)/6; HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36; HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O; 賺錢旅游:FILTER(HJZ3,5),COLORRED,LINETHICK4,NODRAW; STICKLINE(賺錢旅游,O,C,3.3,0),COLORRED; STICKLINE(賺錢旅游,H,L,0.1,0),COLORYELLOW; DRAWTEXT(賺錢旅游,L*0.98,'#39),COLORWHITE,FONTSIZE20; XG:=SUMBARS(FILTER(賺錢旅游,2),1); STICKLINE(XG,REF(H,XG-1),REF(H,XG-1),10,0),COLORGREEN; XG1:=SUMBARS(FILTER(賺錢旅游,2),1); STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF; CC:=VALUEWHEN(賺錢旅游,C); LL:=VALUEWHEN(賺錢旅游,L); HH:=VALUEWHEN(賺錢旅游,H); CROSS(C,CC),SOUND('#39); CROSSDOWN(C,LL),SOUND(''; CROSS(C,HH),SOUND('#39); DRAWTEXT(CROSS(C,HH),HH,'',VALIGN2,FONTSIZE20;? STICKLINE(賺錢旅游,O,C,3.3,0),COLORRED; STICKLINE(賺錢旅游,H,L,0.1,0),COLORYELLOW; DRAWTEXT(賺錢旅游,H*0.98,'#39 ),COLORYELLOW; STICKLINE(XG,REF(C,XG-1),REF(C,XG-1),10,0),COLORGREEN; STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF; STICKLINE(XG,REF(O,XG-1),REF(O,XG-1),10,0),COLORAA00FF; CROSS(C,CC),SOUND(''; CROSSDOWN(C,LL),SOUND(''; 黃金柱:=C>REF(C,1) AND REF(C,1) > REF(C,2) AND REF(C,2) > REF(C,3) AND REF(V,3)>REF(C,2) AND REF(V,2)>REF(V,1) AND REF(V,1)>V;? XX1:=REFX1(黃金柱,3); DRAWCOLORKLINE(XX1,COLORRED,0); 黃金柱1:=C<REF(C,1) AND REF(C,1) < REF(C,2) AND REF(C,2) < REF(C,3) AND REF(V,3)<REF(C,2) AND REF(V,2)<REF(V,1) AND REF(V,1)>V;? XX2:=REFX1(黃金柱1,3); 芝麻開門:FILTER(HJZ3,5),COLORRED,LINETHICK4,NODRAW; STICKLINE(芝麻開門,O,C,3.3,0),COLORRED; STICKLINE(芝麻開門,H,L,0.1,0),COLORYELLOW; DRAWTEXT(芝麻開門,L*0.98,'#39),COLORYELLOW,FONTSIZE20; STICKLINE(XG,REF(H,XG-1),REF(H,XG-1),10,0),COLORGREEN; STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF; CROSS(C,CC),SOUND('#39); CROSSDOWN(C,LL),SOUND(''; CROSS(C,HH),SOUND('#39); DRAWTEXT(CROSS(C,HH),HH,'#39),VALIGN2,FONTSIZE19;? STICKLINE(芝麻開門,O,C,3.3,0),COLORYELLOW; STICKLINE(芝麻開門,H,L,0.1,0),COLORYELLOW; STICKLINE(XG,REF(C,XG-1),REF(C,XG-1),10,0),COLORGREEN; STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF; STICKLINE(XG,REF(O,XG-1),REF(O,XG-1),10,0),COLORAA00FF; CROSS(C,CC),SOUND(''; CROSSDOWN(C,LL),SOUND('';
    DRAWTEXT(ISLASTBAR,頂點,'#39),COLORWHITE; DRAWTEXT(ISLASTBAR,%19.8,'19.8',COLORYELLOW; DRAWTEXT(ISLASTBAR,%38.2,'38.2',COLORMAGENTA,LINETHICK2; DRAWTEXT(ISLASTBAR,%50,'50',COLORRED; DRAWTEXT(ISLASTBAR,%61.8,'61.8',COLORMAGENTA; DRAWTEXT(ISLASTBAR,%80.9,'80.9',COLORYELLOW,LINETHICK2; DRAWTEXT(ISLASTBAR,低點,'#39),COLORWHITE;
    ?

    T:=BARSLAST(CROSS((H>REF(H,1) AND H>REFX(H,1)),0.5)); A:=IF(T=0,H,0); HH1:=VALUEWHEN(T=0,H); H11:=REFX1(HH1,10000); GD:=BARSLAST(CROSS(A>H11,0.5)); DT:=BARSLAST(A=H11); T1:=BARSLAST(CROSS((L<REF(L,1) AND L<REFX(L,1)),0.5)); LT:=BARSLAST(L=LLV(L,GD+1) AND T1=0); LL1:=REFX1(REF(L,T1),10000); LT1:=BARSLAST(L=LL1); DRAWLINE1(CURRBARSCOUNT=REFX1(GD,10000)+1,A,CURRBARSCOUNT=REFX1(DT,10000)+1,H11,1),COLORYELLOW; DRAWLINE1(CURRBARSCOUNT=REFX1(LT,10000)+1,L,CURRBARSCOUNT=REFX1(LT1,10000)+1,L,1),COLORYELLOW;

    ?

  • 網友回復: ? 高:=REF(HHV(H,80),3),COLORWHITE,LINETHICK1;低:=REF(LLV(L,80),3),COLORWHITE,LINETHICK1;H19:=高-(高-低)*0.191,COLORWHITE;H38:=高-(高-低)*0.382,COLORCYAN;H中:=高-(高-低)*0.5,COLORGREEN;H61:=高-(高-低)*0.618,COLORYELLOW;H80:=高-(高-低)*0.809,COLORYELLOW;頂點:REFX1(高,10000),COLORWHITE,LINETHICK1;%19.8:REFX1(H19,10000),COLORWHITE,LINETHICK1;%38.2:REFX1(H38,10000),COLORWHITE,LINETHICK1;%50:REFX1(H中,10000),COLORWHITE,LINETHICK1;%61.8:REFX1(H61,10000),COLORWHITE,LINETHICK1;%80.9:REFX1(H80,10000),COLORWHITE,LINETHICK1;低點:REFX1(低,10000),COLORBLUE,LINETHICK1;
    DRAWTEXT(ISLASTBAR,頂點,'',COLORGREEN,DOT,VALIGN1,FONTSIZE20,DOT;DRAWTEXT(ISLASTBAR,低點,'',COLORRED,DOT,VALIGN1,FONTSIZE20,DOT;?G11:=ZIGZAG(C,1,1)>REF(ZIGZAG(C,1,1),1) AND REF(ZIGZAG(C,1,1),1)<=REF(ZIGZAG(C,1,1),2) AND REF(ZIGZAG(C,1,1),2)<=REF(ZIGZAG(C,1,1),3) AND REF(ZIGZAG(C,1,1),3)<=REF(ZIGZAG(C,1,1),4) AND REF(ZIGZAG(C,1,1),4)<=REF(ZIGZAG(C,1,1),5);X11:=ZIGZAG(C,1,1)<REF(ZIGZAG(C,1,1),1) AND REF(ZIGZAG(C,1,1),1)>=REF(ZIGZAG(C,1,1),2) AND REF(ZIGZAG(C,1,1),2)>=REF(ZIGZAG(C,1,1),3) AND REF(ZIGZAG(C,1,1),3)>=REF(ZIGZAG(C,1,1),4) AND REF(ZIGZAG(C,1,1),4)>=REF(ZIGZAG(C,1,1),5);DRAWTEXT(G11,L,'#39),COLORRED,DOT,VALIGN1,FONTSIZE20;?DRAWTEXT(X11,H,'#39),COLORGREEN,DOT,VALIGN1,FONTSIZE20;
    DRAWCOLORKLINE(G11>0 AND G11>X11,COLORWHITE,0);DRAWCOLORKLINE(X11>0 AND X11>G11,COLORGREEN,0);
    HJZ:=(3*C+H+L+O)/6;HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;賺錢旅游:FILTER(HJZ3,5),COLORRED,LINETHICK4,NODRAW;STICKLINE(賺錢旅游,O,C,3.3,0),COLORRED;STICKLINE(賺錢旅游,H,L,0.1,0),COLORYELLOW;DRAWTEXT(賺錢旅游,L*0.98,'#39),COLORWHITE,FONTSIZE20;XG:=SUMBARS(FILTER(賺錢旅游,2),1);STICKLINE(XG,REF(H,XG-1),REF(H,XG-1),10,0),COLORGREEN;XG1:=SUMBARS(FILTER(賺錢旅游,2),1);STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF;CC:=VALUEWHEN(賺錢旅游,C);LL:=VALUEWHEN(賺錢旅游,L);HH:=VALUEWHEN(賺錢旅游,H);CROSS(C,CC),SOUND('#39);CROSSDOWN(C,LL),SOUND('';CROSS(C,HH),SOUND('#39);DRAWTEXT(CROSS(C,HH),HH,'',VALIGN2,FONTSIZE20;?STICKLINE(賺錢旅游,O,C,3.3,0),COLORRED;STICKLINE(賺錢旅游,H,L,0.1,0),COLORYELLOW;DRAWTEXT(賺錢旅游,H*0.98,'#39 ),COLORYELLOW;STICKLINE(XG,REF(C,XG-1),REF(C,XG-1),10,0),COLORGREEN;STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF;STICKLINE(XG,REF(O,XG-1),REF(O,XG-1),10,0),COLORAA00FF;CROSS(C,CC),SOUND('';CROSSDOWN(C,LL),SOUND('';黃金柱:=C>REF(C,1) AND REF(C,1) > REF(C,2) AND REF(C,2) > REF(C,3) AND REF(V,3)>REF(C,2) AND REF(V,2)>REF(V,1) AND REF(V,1)>V;?XX1:=REFX1(黃金柱,3);DRAWCOLORKLINE(XX1,COLORRED,0);黃金柱1:=C<REF(C,1) AND REF(C,1) < REF(C,2) AND REF(C,2) < REF(C,3) AND REF(V,3)<REF(C,2) AND REF(V,2)<REF(V,1) AND REF(V,1)>V;?XX2:=REFX1(黃金柱1,3);芝麻開門:FILTER(HJZ3,5),COLORRED,LINETHICK4,NODRAW;STICKLINE(芝麻開門,O,C,3.3,0),COLORRED;STICKLINE(芝麻開門,H,L,0.1,0),COLORYELLOW;DRAWTEXT(芝麻開門,L*0.98,'#39),COLORYELLOW,FONTSIZE20;STICKLINE(XG,REF(H,XG-1),REF(H,XG-1),10,0),COLORGREEN;STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF;CROSS(C,CC),SOUND('#39);CROSSDOWN(C,LL),SOUND('';CROSS(C,HH),SOUND('#39);DRAWTEXT(CROSS(C,HH),HH,'#39),VALIGN2,FONTSIZE19;?STICKLINE(芝麻開門,O,C,3.3,0),COLORYELLOW;STICKLINE(芝麻開門,H,L,0.1,0),COLORYELLOW;STICKLINE(XG,REF(C,XG-1),REF(C,XG-1),10,0),COLORGREEN;STICKLINE(XG1,REF(L,XG1-1),REF(L,XG1-1),10,0),COLORAA00FF;STICKLINE(XG,REF(O,XG-1),REF(O,XG-1),10,0),COLORAA00FF;CROSS(C,CC),SOUND('';CROSSDOWN(C,LL),SOUND('';
    DRAWTEXT(ISLASTBAR,頂點,'#39),COLORWHITE;DRAWTEXT(ISLASTBAR,%19.8,'19.8',COLORYELLOW;DRAWTEXT(ISLASTBAR,%38.2,'38.2',COLORMAGENTA,LINETHICK2;DRAWTEXT(ISLASTBAR,%50,'50',COLORRED;DRAWTEXT(ISLASTBAR,%61.8,'61.8',COLORMAGENTA;DRAWTEXT(ISLASTBAR,%80.9,'80.9',COLORYELLOW,LINETHICK2;DRAWTEXT(ISLASTBAR,低點,'#39),COLORWHITE;
    ?

    T:=BARSLAST(CROSS((H>REF(H,1) AND H>REFX(H,1)),0.5));A:=IF(T=0,H,0);HH1:=VALUEWHEN(T=0,H);H11:=REFX1(HH1,10000);GD:=BARSLAST(CROSS(A>H11,0.5));DT:=BARSLAST(A=H11);T1:=BARSLAST(CROSS((L<REF(L,1) AND L<REFX(L,1)),0.5));LT:=BARSLAST(L=LLV(L,GD+1) AND T1=0);LL1:=REFX1(REF(L,T1),10000);LT1:=BARSLAST(L=LL1);DRAWLINE1(CURRBARSCOUNT=REFX1(GD,10000)+1,A,CURRBARSCOUNT=REFX1(DT,10000)+1,H11,1),COLORYELLOW;DRAWLINE1(CURRBARSCOUNT=REFX1(LT,10000)+1,L,CURRBARSCOUNT=REFX1(LT1,10000)+1,L,1),COLORYELLOW;

    ?

    ?

    ?

    修改一下? 安裝 不了?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  點擊這里給我發消息或微信:cxhjy888 進行 有償 編寫!不貴!點擊查看價格!


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
新疆18选7基本走势带坐标