您現在的位置:程序化交易>> 期貨公式>> 文華財經>> 文華財經知識>>正文內容

老師請把通達信副圖macd修改成文華的 [文華財經]

  • 咨詢內容:

    DIFF?:(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),?COLORYELLOW;
    DEA?:?EMA(DIFF,9),COLORRED,LINETHICK2;
    ?DIF:IF(DIFF<REF(DIFF,1),DIFF,DRAWNULL),?COLORGRAY;
    ??ADEA:IF(DEA<REF(DEA,1),DEA,DRAWNULL),?COLORCYAN,LINETHICK2;
    ?MACD:2*(DIFF-DEA),?COLORSTICK,LINETHICK2;?

    低位金叉:=CROSS(DIFF,DEA)?AND?DIFF<-0.1;
    STICKLINE(低位金叉,0,0.30,3,0),COLORMAGENTA;
    JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
    二次金叉:=CROSS(DIFF,DEA)?AND?DEA<0?AND?COUNT(JCCOUNT=2,21)=1;
    STICKLINE(二次金叉,0,0.80,3,0),COLORYELLOW;
    DRAWICON(二次金叉,DEA*0.9,1)?;
    DRAWICON(CROSS(DIFF,DEA),DEA*1.02,1);
    DRAWICON(CROSS(DEA,DIFF),DIFF*0.98,2);
    A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
    底背離:=REF(CLOSE,A1+1)>CLOSE?AND?DIFF>REF(DIFF,A1+1)?AND?CROSS(DIFF,DEA)?AND?DIFF<0;
    STICKLINE(底背離,0,0.40,3,0), COLORBROWN;  

    DRAWTEXT(二次金叉,0.1,'nbsp;二次金叉',COLORYELLOW;

    底背:DRAWLINE(A1=0,DEA,底背離,DEA,0),COLORWHITE,LINETHICK1;
    DRAWTEXT(底背離,DIFF,'nbsp;底背離',COLORWHITE;
    A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
    頂背離:=REF(CLOSE,A2+1)<CLOSE?AND?REF(DIFF,A2+1)>DIFF?AND?CROSS(DEA,DIFF);
    頂背:DRAWLINE(A2=0,DEA,頂背離,DEA,0),COLORLIGRAY,LINETHICK1;  

    ?

    ?來源:程序化99

  • 文華技術人員: 參考:
    DIFF :(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26), COLORYELLOW; DEA : EMA(DIFF,9),COLORRED,LINETHICK2; DIF:IF(DIFF<REF(DIFF,1),DIFF,NULL), COLORGRAY; ADEA:IF(DEA<REF(DEA,1),DEA,NULL), COLORCYAN,LINETHICK2; MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;?
    低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1; STICKLINE1(低位金叉,0,0.30,3,0),COLORMAGENTA; JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0)); 二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1; STICKLINE1(二次金叉,0,0.80,3,0),COLORYELLOW; DRAWICON(二次金叉,DEA*0.9,1) ; DRAWICON(CROSS(DIFF,DEA),DEA*1.02,1); DRAWICON(CROSS(DEA,DIFF),DIFF*0.98,2); A1:=BARSLAST(REF(CROSS(DIFF,DEA),1)); 底背離:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA) AND DIFF<0; STICKLINE1(底背離,0,0.40,3,0),RGB(128,64,64); DRAWTEXT(二次金叉,0.1,' 二次金叉'),COLORYELLOW; DRAWLINE3(底背離,DEA,0,底背離,REF(DEA,BARSLAST(A1=0)+1),BARSLAST(A1=0)+1,0),COLORWHITE,LINETHICK1; DRAWTEXT(底背離,DIFF,' 底背離'),COLORWHITE; A2:=BARSLAST(REF(CROSS(DEA,DIFF),1)); 頂背離:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF); DRAWLINE3(頂背離,DEA,0,頂背離,REF(DEA,BARSLAST(A2=0)+1),BARSLAST(A2=0)+1,0),COLORLIGHTGREY,LINETHICK1; ?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  點擊這里給我發消息或微信:cxhjy888 進行 有償 編寫!不貴!點擊查看價格!


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
新疆18选7基本走势带坐标