您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

神獒密鑰神獒贏富主圖指標公式副圖指標公式一套[大智慧公式]

相關標簽:主升副圖指標公式源碼 、 神獒贏富指標 說明 、 現貨主圖指標公式源碼 、 通達信主圖指標源碼 、 波浪指標主圖指標源碼 、 文華贏順指標公式源碼 、 黃藍帶主圖指標源碼 、 狙擊主力副圖指標源碼 、 波段指標源碼及副圖 、 135戰法副圖指標源碼 、 均線買賣主圖指標源碼 、 強勢牛股主圖指標源碼 、 富遠指標源碼 、 好用主圖指標 源碼 、 黃金坑指標源碼主圖 、

 

神獒贏富主圖副圖一套 源碼神獒密鑰

 

 

原理解析:


 

 

源碼:


DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));
A1:=(25);
A2:=(26);
A3:=(3 * (SMA((((CLOSE - (LLV(LOW,A1))) / ((HHV(HIGH,A1)) - (LLV(LOW,A1)))) * 100),5,1))) - (2 * (SMA((SMA((((CLOSE - (LLV(LOW,A2))) / ((HHV(HIGH,A2)) - (LLV(LOW,A2)))) * 100),5,1)),3,1)));
A4:=(3 * (SMA((((INDEXC - (LLV(INDEXL,A1))) / ((HHV(INDEXH,A1)) - (LLV(INDEXL,A1)))) * 100),5,1))) - (2 * (SMA((SMA((((INDEXC - (LLV(INDEXL,A2))) / ((HHV(INDEXH,A2)) - (LLV(INDEXL,A2)))) * 100),5,1)),3,1)));
星座趨勢:EMA(A3,5),linethick0;
A5:=REF(星座趨勢,1);
A6:=EMA(A3,3);
大盤線:EMA(A4,3),colorMagenta;
A7:=星座趨勢 > A5;
A8:=星座趨勢 < A5;
A9:=((CLOSE / (REF(CLOSE,1))) - 1) * 100;
A10:=(IF((DATE <= 1091025),1,0)) * (IF((CURRENTDATE <= 1091025),1,0));
A11:=BIGORDER(1,3);
A12:=BIGORDER(2,3);
A13:=BIGORDER(1,2);
A14:=BIGORDER(2,2);
A15:=((((A13 - A14) * VOL) / CAPITAL) * 500) * A10;
A16:=((((A11 - A12) * VOL) / CAPITAL) * 500) * A10;
A17:=IF(((A15 >= 0) AND (A16 >= 0)),(MAX(A15,A16)),(MIN(A15,A16)));
A18:=IF((A9 > 0),A9,ABS(A9));
A19:=IF(((A17 > 0) AND (A9 < 0)),A9,A18);
A20:=A17 - A19;
爆破:IF((A20 > 0),A20,0),linethick0,colorRed;
A21:=((CLOSE - (EMA(CLOSE,25))) / (EMA(CLOSE,25))) * 100;
A22:=((CLOSE - CYC(13)) / CYC(13)) * 100;
A23:=IF((CLOSE < 800),((AMOUNT / VOL) / 100),((((CLOSE * 2) + HIGH) + LOW) / 4));
A24:=((EMA((MA(A23,3)),3)) + (WMA(A23,5))) / 2;
A25:=REF(A24,1);
A26:=BARSCOUNT(CLOSE);
A27:=IF((A26 = 1),0,(((A24 - A25) / A25) * 100));
神獒密鑰①:(((A20 > 6) AND (A27 < -3.5)) AND (A22 < -18)) AND (A21 > -20),linethick0,ColorFF4398;
STICKLINE(神獒密鑰①,10,0,2,0),linethick0,ColorFF4398;
DRAWTEXT(神獒密鑰①,A20,'神獒密鑰①成功率93%'),ColorFF4398;
神獒密鑰②:(((A20 >= 5) AND (A27 < -3)) AND (A21 < -22)) AND (A22 < -22),linethick0,ColorFFFF98;
STICKLINE(神獒密鑰②,12,0,2,0),linethick0,ColorFFFF98;
DRAWTEXT(神獒密鑰②,A20,'神獒密鑰②成功率97%'),ColorFFFF98;
神獒密鑰●:((((A20 >= 8) AND (A27 < -5)) AND (A21 < -13)) AND (A22 < -16)) AND (A15 >= 1),linethick0,Color00FDFF;
STICKLINE(神獒密鑰●,14,0,2,0),linethick0,Color00FDFF;
DRAWTEXT(神獒密鑰●,A20,'神獒密鑰●成功率99%'),Color00FDFF;
神獒密鑰④:((((A20 >= 4) AND (A27 < -4)) AND (A21 < -10)) AND (A22 < -12)) AND (A15 >= 0.5),linethick0,ColorFFF6FF;
STICKLINE(神獒密鑰④,14,0,2,0),linethick0,ColorFFF6FF;
DRAWTEXT(神獒密鑰④,A20,'神獒密鑰④成功率90%'),ColorFFF6FF;
神獒密鑰⑤:((((A20 >= 4) AND (A27 < -3)) AND (A21 < -10)) AND (A22 < -13)) AND (A15 >= 0.5),linethick0,ColorFFF6FF;
STICKLINE(神獒密鑰⑤,14,0,2,0),linethick0,ColorFFF6FF;
DRAWTEXT(神獒密鑰⑤,A20,'神獒密鑰⑤成功率90%'),ColorFFF6FF;
二級:((((A20 >= 4) AND (A15 > 0.2)) AND (A27 < -4)) AND (A22 < -14)) AND (A21 > -10),linethick0,colorGreen;
三級:((((A20 >= 6) AND (A27 < -2.5)) AND (A22 < -18)) AND (A21 < -14)) AND (A15 > 0.2),linethick0,colorMagenta;
四級:((A20 >= 8) AND (A27 < -5)) AND (A22 < -18),linethick0,colorRed;
五級:((A20 >= 10) AND ((A15 > 1) OR (A16 > 2.5))) AND (A15 > 0.2),linethick0,ColorFF0000;
DRAWTEXTREL(0,0,' 密鑰爆破級數越高意味著成功率越高。'),linethick1,colorRed;
STICKLINE(二級,14,0,2,0),colorGreen;
STICKLINE(三級,13,0,4,0),colorMagenta;
STICKLINE(四級,12,0,6,0),colorRed;
STICKLINE(((A20 >= 10) AND ((A15 > 1) OR (A16 > 2.5))),10,0,8,0),ColorFF0000;
STICKLINE(((A20 > 5) AND (A15 > 1)),(A20 * 2),0,0.5,0),colorYellow;
STICKLINE(A8,星座趨勢,A5,6,0),Color3DFF3D;
STICKLINE(A8,星座趨勢,A5,5,0),Color51FF51;
STICKLINE(A8,星座趨勢,A5,4,0),Color65FF65;
STICKLINE(A8,星座趨勢,A5,3,0),Color7AFF7A;
STICKLINE(A8,星座趨勢,A5,2,0),Color8EFF8E;
STICKLINE(A8,星座趨勢,A5,1,0),ColorA2FFA2;
STICKLINE(A7,星座趨勢,A5,6,0),Color2828FF;
STICKLINE(A7,星座趨勢,A5,5,0),Color3D3DFF;
STICKLINE(A7,星座趨勢,A5,4,0),Color5151FF;
STICKLINE(A7,星座趨勢,A5,3,0),Color6565FF;
STICKLINE(A7,星座趨勢,A5,2,0),Color7A7AFF;
STICKLINE(A7,星座趨勢,A5,1,0),Color8E8EFF;
IF((((CROSS(A5,星座趨勢)) AND (星座趨勢 > 85)) AND (((((A13 - A14) * VOL) / CAPITAL) * 500) < -0.65)),70,90);
IF((((CROSS(星座趨勢,A5)) AND (星座趨勢 < 15)) AND (((((A13 - A14) * VOL) / CAPITAL) * 500) > 0.3)),20,10);
DRAWTEXTREL(10,900,'㊣十二星座*神獒贏富㊣'),linethick1,COLOR00EEff;
神獒炎律
input:N(5,1,100);
幅度:=ABS((C-REF(C,1))/REF(C,1));
轉折:=IF(C>=O,幅度,0-幅度);
變異速度:=轉折*1000000/INDEXC;
神獒:SUM(變異速度,n),linethick2,COLORRED;
定律:SUM(0-變異速度,n),linethick2,coloryellow;
LC:=REF(CLOSE,1);
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:= EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
容量比率:=SUM(IF(CLOSE>LC,VOL,0),26)*100/SUM(IF(CLOSE<=LC,VOL,0),26);
審判:(容量比率<70 OR CROSS(DIFF,DEA)) AND CROSS(神獒,定律) AND C/L>1.02,linethick2,colorwhite;
DRAWICON(審判,0,7);Var1:=EMA(HHV(HIGH,500),21);
Var2:=EMA(HHV(HIGH,250),21);
Var3:=EMA(HHV(HIGH,90),21);
Var4:=EMA(LLV(LOW,500),21);
Var5:=EMA(LLV(LOW,250),21);
Var6:=EMA(LLV(LOW,90),21);
Var7:=EMA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558+Var2*0.558+Var3*0.558)/6,21);
Var8:=EMA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+Var2*0.55+Var3*0.65)/6,21);
Var9:=EMA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var2*0.68+Var3*0.68)/6,21);
VarA:=EMA((Var7*3+Var8*2+Var9)/6*1.738,21);
VarB:=REF(LOW,1);
VarC:=SMA(ABS(LOW-VarB),3,1)/SMA(MAX(LOW-VarB,0),3,1)*100;
VarD:=EMA(IF(CLOSE*1.35<=VarA,VarC*10,VarC/10),3);
VarE:=LLV(LOW,30);
VarF:=HHV(VarD,30);
Var10:=IF(MA(CLOSE,58),1,0);
神炎:EMA(IF(LOW<=VarE,(VarD+VarF*2)/2,0),3)/618*Var10,coloryellow;
邪炎:=STICKLINE(神炎>0 ,0 ,神炎 ,4 ,1);
㊣:神炎,colorred;
STICKLINE(神炎>0,0 ,㊣*1.2,8,0 ),COLOR00EEff;
STICKLINE(神炎>0,0 ,㊣*0.8,8,0 ),COLOR00BBff;
STICKLINE(神炎>0,0 ,㊣*0.6,8,0 ),COLOR0099ff;
STICKLINE(神炎>0,0 ,㊣*0.4,8,0 ),COLOR0066ff;
STICKLINE(神炎>0,0 ,㊣*0.2,8,0 ),COLOR0000ff;M5:=EMA(C,43);
M6:=EMA(C,55);
M7:=MA(C,78);
M8:=EMA(M7,3);
M9:=EMA(M8,3);
M11:=EMA(M9,3);
MA47:=EMA(CLOSE,46);
MA60:=EMA(CLOSE,60);
Y:=(H+L)/2;
AO:=MA(Y,5)-MA(Y,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3<TUD3,REF(HHV(H,2),TDU3),REF(LLV(L,2),TUD3));
JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0<TUD0;
JUD0:=REF(C,1)>=REF(UDGLINE,1) AND C<UDGLINE AND TUD0<TDU0;
JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
㊣神:JDU2 AND M9*0.90,colorwhite;
DRAWTEXT(㊣神,(LOW * 0.98),'㊣'),linethick2,ALIGN1,coloryellow;
DRAWTEXTREL(10,800,'㊣十二星座*神獒贏富㊣'),linethick1,COLOR00EEff;
DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));神獒主圖DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));
a1:=(IF((DATE <= 1091025),1,0)) * (IF((CURRENTDATE <= 1091025),1,0));
DRAWGBK((CLOSE > 0),'5');
a2:=IF((CLOSE < 800),((AMOUNT / VOL) / 100),((((CLOSE * 2) + HIGH) + LOW) / 4));
a3:=((HHV(HIGH,15)) + (LLV(LOW,30))) / 2;
a4:=EMA((MA(a2,5)),10);
a5:=EMA((MA(a2,15)),10);
a6:=EMA((MA(a2,13)),21);
a7:=((a4 + a5) + a6) / 3;
a8:=(((REF(a7,1)) + a7) + (REF(a7,2))) / 3;
決策線:EMA((MA(CLOSE,5)),3),colorGreen;
PARTLINE(決策線,決策線 > (REF(決策線,3)),RGB(255,0,0)),linethick1,colorRed;
UPR:決策線 + (3 * (STD(決策線,10))),Color808000;
DWN:決策線 - (3 * (STD(決策線,10))),ColorA10000;
多空價:a8 * a1,linethick2,Color008E00;
半年線:MA(CLOSE,120),POINTDOT,linethick4,colorGray;
年線:MA(CLOSE,250),CROSSDOT,Color717143;
STICKLINE((CLOSE > OPEN),HIGH,LOW,0.0001,1),colorRed;
STICKLINE((CLOSE > OPEN),OPEN,CLOSE,8,1),Color5050FF;
STICKLINE((CLOSE < OPEN),OPEN,CLOSE,8,0),ColorFFFF85;
STICKLINE((CLOSE < OPEN),HIGH,LOW,0.0001,0),colorCyan;
a9:=((EMA((MA(a2,3)),3)) + (WMA(a2,5))) / 2;
a10:=REF(a9,1);
a11:=BARSCOUNT(CLOSE);
a12:=IF((a11 = 1),0,(((a9 - a10) / a10) * 100));
a13:=REF(CLOSE,1);
a14:=IF((a11 = 1),0,(((CLOSE - a13) / a13) * 100));
a15:=IF((a11 = 1),((CLOSE + OPEN) / 2),a10);
a16:=REF(a9,2);
a17:=((a9 + a10) + a16) / 3;
a18:=((ABS((a9 - a17)) + ABS((a10 - a17))) + ABS((a16 - a17))) / 3;
a19:=IF((a11 < 3),0,((a18 / a9) * 100));
a20:=IF((((a12 > 0.5) AND ((a19 > 0.215) OR (LOW > a15))) AND (CLOSE >= OPEN)),1,0);
a21:=IF((((a12 < (0 - 0.3)) AND ((a19 > 0.2) OR (HIGH < a15))) AND ((OPEN >= CLOSE) OR (a14 < -1))),1,0);
B:((COUNT(a20,BARSLAST(a21))) = 1) AND a20,linethick0;
D:((COUNT(a21,BARSLAST(a20))) = 1) AND a21,linethick0;
a22:=BARSLAST(B);
a23:=((SUM(D,a22)) = 0) * a22;
a24:=a23 > 0;
a25:=a23 = 0;
STICKLINE(a24,CLOSE,OPEN,8,0),colorMagenta;
STICKLINE(a24,CLOSE,OPEN,7,0),ColorFF28FF;
STICKLINE(a24,CLOSE,OPEN,6,0),ColorFF3DFF;
STICKLINE(a24,CLOSE,OPEN,5,0),ColorFF51FF;
STICKLINE(a24,CLOSE,OPEN,4,0),ColorFF65FF;
STICKLINE(a24,CLOSE,OPEN,3,0),ColorFF7AFF;
STICKLINE(a24,CLOSE,OPEN,2,0),ColorFF8EFF;
STICKLINE(a24,CLOSE,OPEN,1,0),ColorFFA2FF;
STICKLINE(a25,CLOSE,OPEN,8,0),ColorFFFD02;
STICKLINE(a25,CLOSE,OPEN,7,0),ColorF8FF24;
STICKLINE(a25,CLOSE,OPEN,6,0),ColorFDFF4A;
STICKLINE(a25,CLOSE,OPEN,5,0),ColorFCFF69;
STICKLINE(a25,CLOSE,OPEN,4,0),ColorFDFD97;
STICKLINE(a25,CLOSE,OPEN,3,0),ColorFFFFA2;
STICKLINE(a25,CLOSE,OPEN,2,0),ColorFFFFB6;
STICKLINE(a25,CLOSE,OPEN,1,0),ColorFFFFCC;
STICKLINE(B,CLOSE,OPEN,8,0),colorYellow;
STICKLINE(D,CLOSE,OPEN,8,0),Color00BE00;
DRAWTEXT(B,(LOW * 0.98),'㊣'),linethick2,ALIGN1,colorWhite;
DRAWTEXT(D,(HIGH * 1.035),'S'),linethick2,ALIGN1,colorGreen;
PARTLINE(決策線,決策線 > (REF(決策線,3)),RGB(255,0,0)),linethick1,colorRed;
a26:=(((CLOSE / a13) - 1) * 100) >= (7 * a1);
a27:=HIGH - ((HIGH - LOW) / 3);
a28:=LOW + ((HIGH - LOW) / 3);
PARTLINE(多空價,多空價 > (REF(多空價,3)),RGB(255,0,0)),linethick2,colorRed;
DRAWTEXTREL(10,800,'㊣十二星座*神獒贏富㊣'),linethick1,COLOR00EEff;
DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

 

 


參數設置
N 5 1 111 1N1 10 1 111 1
P 3 0.1 30 1
M 21 0 100 1
間限制的問題,請把相關的代碼a1:=(IF((DATE <= 1091025),1,0)) * (IF((CURRENTDATE <= 1091025),1,0));刪除即可。
再把代碼中出現a1的地方用1替代。
神獒密鑰中1091025這個數字改成1CXH:=STRTONUM(STRRIGHT(DATESTR(CURRENTDATE),1));
WARNING('http://www.myblss.tw',CURRENTTIME>180000 and (CXH=1 OR CXH=6));
DRAWTEXTREL(10 ,10 ,'指標公式');

 

 

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

 

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  有需要幫忙請點擊這里留言!!!進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  新疆18选7基本走势带坐标