您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

組合公式四共振抓住牛股啟動點源碼[大智慧公式]

相關標簽:指標共振買賣點公式 、 牛股啟動預警指標公式 、 牛股指標起爆點公式 、 通達信共振抓牛股指標 、 通達信共振啟動指標 、 多指標共振公式 、 資金共振指標公式 、 均線共振指標公式 、 周期共振指標公式 、 指標共振選股公式 、 六共振指標公式 、 五指標共振公式 、 共振起爆點指標 、 通達信牛股啟動指標 、 牛股起爆指標公式 、

 

四共振抓住牛股啟動點 組合公式bs操盤線(主圖)發出買點指示,多空能量線多方戰勝空方,抄底信號指標發出買入信號,博弈資金指標顯示主力資金入場,四共振抓住牛股啟動點源碼BS操盤線(主圖)

 

 

原理解析:


 

 

源碼:


買線:=EMA(C,2);
賣線:=EMA(SLOPE(C,21)*20+C,42);
BU:=cross(買線,賣線);
SEL:=cross(賣線,買線);
drawtext(bu,LOW*0.989,'B'),colorred,linethick3;
DRAWTEXT(bu,LOW,''),Color208FFF,LINETHICK3;
DRAWTEXT(sel,HIGH,''),ColorFFFF00,LINETHICK3;
drawtext(sel,HIGH*1.0175,'S'),colorffff00,linethick3;
stickline(買線>=賣線,low,high,1,0),colorred;
stickline(買線>=賣線,close,open,4.5,0),color0000aa;
stickline(買線>=賣線,close,open,4,0),color0000cc;
stickline(買線>=賣線,close,open,3,0),color0000cc;
stickline(買線>=賣線,close,open,2,0),color0000ee;
stickline(買線<賣線,close,open,4.5,0),coloraaaa00;
stickline(買線<賣線,close,open,4,0),colorbbbb00;
stickline(買線<賣線,close,open,3,0),colorcccc00;
stickline(買線<賣線,close,open,2,0),coloreeee00;
stickline(買線<賣線,low,high,1,0),colorffff00;
stickline(cross(買線,賣線) or cross(賣線,買線),open,close,3,0),color00ffff;
指導線: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),linethick1,ColorFFffFF;
界: MA(CLOSE,27),linethick1,Color00FFFF;
DRAWTEXT(cross(指導線,界),界,''),Colorffffff;
DRAWTEXT(cross(界,指導線),界,''),Color00ffff;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
G:=95;
DRAWTEXT(cross(J,D),L*0.999,''),Color00ffff,linethick4;
DRAWTEXT(cross(J,D),L,''),Color00ffff;
DRAWTEXT(cross(J,G),H*1.005,''),Colorffff00,linethick4;
DRAWTEXT(cross(J,G),H,''),Colorffff00;多空能量線
VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
機構做空能量線: SMA(VAR1,3,1),LINETHICK2,COLORGREEN;
VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
機構做多能量線: SMA(VAR2,5,1)-8,LINETHICK2,COLORRED;
弱勢區:20,POINTDOT,COLORGREEN;
強弱分水嶺:50,POINTDOT,COLORWHITE;
強勢區:80,POINTDOT,COLORF00FF0;抄底信號
大主力: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1), ,LINETHICK2, ;
抄底信號: 10, ,LINETHICK2,COLORRED ;
買入個股: IF(CROSS(大主力,抄底信號),100,10), ,LINETHICK2,COLORYELLOW;
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3); VB:=(V9-VA)/2;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
莊家撤: IF(V4<=0,V4,0),COLORGREEN;
莊家進: IF(V4>=0,V4,0),COLORRED;
主力資金進: IF(VB>=0,VB,0),COLORYELLOW;
主力資金撤: IF(VB<=0,VB,0),COLORBLUE;
博弈資金
a:=if((close>126.32),(amount)/(100000),vol);
主力:ma(a,4),linestick,coloryellow;
游資:ma(a,8),linestick,color00ff00;
大戶:ma(a,16),linestick,colorred;
散戶:ma(a,32),linestick,colorf0f000;
主比:abs(((主力)/(主力 + 游資 + 大戶 + 散戶))*(100)),linestick,coloryellow;
游比:abs(((游資)/(主力 + 游資 + 大戶 + 散戶))*(100)),linestick,color00ff00;
大比:abs(((大戶)/(主力 + 游資 + 大戶 + 散戶))*(100)),linestick,colorred;
散比:abs(((散戶)/(主力 + 游資 + 大戶 + 散戶))*(100)),linestick,colorf0f000;
警戒線:ma(a,180),colorff66ff,linethick2;
stickline((主力 > 0),0,主力,7,0),colorred;
stickline((主力 > 0),0,主力,6.3,0),color0022ff;
stickline((主力 > 0),0,主力,5.5,0),color007aff;
stickline((主力 > 0),0,主力,5.3,0),color0080ff;
stickline((主力 > 0),0,主力,5,0),color0089ff;
stickline((主力 > 0),0,主力,4.5,0),color00abff;
stickline((主力 > 0),0,主力,0.7,0),coloryellow;
stickline((游資 > 0),0,游資,6.8,0),color009500;
stickline((游資 > 0),0,游資,6.3,0),color00a300;
stickline((游資 > 0),0,游資,6,0),color00ab00;
stickline((游資 > 0),0,游資,5,0),color00c100;
stickline((游資 > 0),0,游資,3,0),color00db00;
stickline((游資 > 0),0,游資,2.5,0),color00ea00;
stickline((游資 > 0),0,游資,1.1,0),colorgreen;
stickline((大戶 > 0),0,大戶,6,0),color1020aa;
stickline((大戶 > 0),0,大戶,4,0),color1020cc;
stickline((大戶 > 0),0,大戶,3,0),color1020ee;
stickline((大戶 > 0),0,大戶,2,0),color1020ff;
stickline((散戶 > 0),0,散戶,6,0),colorff7700;
stickline((散戶 > 0),0,散戶,5,0),colorffaa00;
stickline((散戶 > 0),0,散戶,4,0),colorffbb00;
stickline((散戶 > 0),0,散戶,3,0),colorffcc00;
stickline((散戶 > 0),0,散戶,2,0),colorffdd00;
stickline((散戶 > 0),0,散戶,1,0),colorffee00;
CXH:=STRTONUM(STRRIGHT(DATESTR(CURRENTDATE),1));
WARNING('http://www.myblss.tw',CURRENTTIME>180000 and (CXH=1 OR CXH=6));
DRAWTEXTREL(10 ,10 ,'指標公式');

 

 

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

 

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  有需要幫忙請點擊這里留言!!!進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  新疆18选7基本走势带坐标