您現在的位置:程序化交易>> 外匯現貨>> 倚天財經>> 倚天版公式>>正文內容

散戶主力資金流指標源碼[倚天版公式]

M:=55;
N:=34;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(85,RSI),75,'▼'),COLORGREEN;
VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR2:=REF(LOW,1)*VAR1;
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3)*VAR1;
VAR5:=LLV(LOW,30)*VAR1;
VAR6:=HHV(VAR4,30)*VAR1;
VAR7:=IF(MA(CLOSE,58),1,0)*VAR1;
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;
吸籌:IF(VAR8>100,100,VAR8)*VAR1,COLORRED;
莊家吸籌:STICKLINE(吸籌>-150,0,吸籌,8,0),COLORRED;
散戶線: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORFFFF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
莊家線:EMA(J,6),COLORFF00FF,LINETHICK2;

 

源碼解析:

M賦值:55
N賦值:34
LC賦值:昨收
RSI賦值:(((收盤價-LC)和0的較大值的3日[1日權重]移動平均 / (收盤價-LC)的絕對值的3日[1日權重]移動平均) * 100)
FF賦值:收盤價的3日指數移動平均
MA15賦值:收盤價的21日指數移動平均
當滿足條件85上穿RSI時,在75位置書寫文字,畫綠色
VAR1賦值:如果年份>=2038ANDMONTH>=1,返回0,否則返回1
VAR2賦值:昨日最低價*VAR1
VAR3賦值:最低價-VAR2的絕對值的3日[1日權重]移動平均/最低價-VAR2和0的較大值的3日[1日權重]移動平均*100*VAR1
VAR4賦值:如果收盤價*1.3,返回VAR3*10,否則返回VAR3/10的3日指數移動平均*VAR1
VAR5賦值:30日內最低價的最低值*VAR1
VAR6賦值:30日內VAR4的最高值*VAR1
VAR7賦值:如果收盤價的58日簡單移動平均,返回1,否則返回0*VAR1
VAR8賦值:如果最低價<=VAR5,返回(VAR4+VAR6*2)/2,否則返回0的3日指數移動平均/618*VAR7*VAR1
輸出吸籌:如果VAR8>100,返回100,否則返回VAR8*VAR1,畫紅色
輸出莊家吸籌:當滿足條件吸籌>-150時,在0和吸籌位置之間畫柱狀線,寬度為8,0不為0則畫空心柱.,畫紅色
輸出散戶線: 100*(M日內最高價的最高值-收盤價)/(M日內最高價的最高值-M日內最低價的最低值),COLORFFFF00,線寬為2
RSV賦值:(收盤價-N日內最低價的最低值)/(N日內最高價的最高值-N日內最低價的最低值)*100
K賦值:RSV的3日[1日權重]移動平均
D賦值:K的3日[1日權重]移動平均
J賦值:3*K-2*D
輸出莊家線:J的6日指數移動平均,COLORFF00FF,線寬為2
 
 

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  新疆18选7基本走势带坐标