您現在的位置:程序化交易>> 外匯現貨>> 倚天財經>> 倚天版公式>>正文內容

倚天逃出苦海指標[倚天版公式]

AA:MA(WINNER(C*0.95)*100,3),COLORYELLOW;
AA,stick,COLORYELLOW,linethick2;
Var1:=1/WINNER(CLOSE);
Var2:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
Var3:=100-ABS(Var2);
Var4:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var5:=3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var6:=100-Var5;
Var7:=100-Var4;
Var8:=MA(WINNER(CLOSE*0.95)*100,3);
Var9:=IF(Var1>5,IF(Var1<100,Var1,Var3-10),0);
VarA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VarB:=SMA(VarA,3,1);
VarC:=SMA(VarB,3,1);
探索: EMA(3*VarB-2*VarC,3),colorwhite;
主力: (-1)*(EMA(Var7,1)-50)+50,COLORYELLOW,linethick2;
Z1: MA(主力,9),COLORRED,linethick2;
VarD:=(-1)*(EMA(Var7,1)-50)+50;
VarE:=(-1)*(EMA(Var7,12)-50)+50;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
天涯:if(rsi1>93 or (AA>90 and rsi1>80),80,100),;
海角: 0,colorgreen;
苦海:EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6),LINESTICK,;
ZS: MA(探索,3),COLORYELLOW;
ZM: MA(MA(探索,3),3),COLORGREEN; 

 

源碼解析:

輸出AA:以收盤價*0.95計算的獲利盤比例*100的3日簡單移動平均,畫黃色
AA,STICK,畫黃色,線寬為2
VAR1賦值:1/以收盤價計算的獲利盤比例
VAR2賦值:(收盤價-收盤價的13日簡單移動平均)/收盤價的13日簡單移動平均*100
VAR3賦值:100-VAR2的絕對值
VAR4賦值:3*(收盤價-75日內最低價的最低值)/(75日內最高價的最高值-75日內最低價的最低值)*100的20日[1日權重]移動平均-2*(收盤價-75日內最低價的最低值)/(75日內最高價的最高值-75日內最低價的最低值)*100的20日[1日權重]移動平均的15日[1日權重]移動平均
VAR5賦值:3*(開盤價-75日內最低價的最低值)/(75日內最高價的最高值-75日內最低價的最低值)*100的20日[1日權重]移動平均-2*(開盤價-75日內最低價的最低值)/(75日內最高價的最高值-75日內最低價的最低值)*100的20日[1日權重]移動平均的15日[1日權重]移動平均
VAR6賦值:100-VAR5
VAR7賦值:100-VAR4
VAR8賦值:以收盤價*0.95計算的獲利盤比例*100的3日簡單移動平均
VAR9賦值:如果VAR1>5,返回如果VAR1<100,返回VAR1,否則返回VAR3-10,否則返回0
VARA賦值:(收盤價-9日內最低價的最低值)/(9日內最高價的最高值-9日內最低價的最低值)*100
VARB賦值:VARA的3日[1日權重]移動平均
VARC賦值:VARB的3日[1日權重]移動平均
輸出探索: 3*VARB-2*VARC的3日指數移動平均,畫白色
輸出主力: (-1)*(VAR7的1日指數移動平均-50)+50,畫黃色,線寬為2
輸出Z1: 主力的9日簡單移動平均,畫紅色,線寬為2
VARD賦值:(-1)*(VAR7的1日指數移動平均-50)+50
VARE賦值:(-1)*(VAR7的12日指數移動平均-50)+50
賦值: 昨收
RSI1賦值:收盤價-LC和0的較大值的6日[1日權重]移動平均/收盤價-LC的絕對值的6日[1日權重]移動平均*100
輸出天涯:如果RSI1>93OR(AA>90ANDRSI1>80),返回80,否則返回100,
輸出海角: 0,畫綠色
輸出苦海:100*(14日內最高價的最高值-收盤價)/(14日內最高價的最高值-14日內最低價的最低值)的6日指數移動平均,LINESTICK,
輸出ZS: 探索的3日簡單移動平均,畫黃色
輸出ZM: 探索的3日簡單移動平均的3日簡單移動平均,畫綠色
 
 

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  新疆18选7基本走势带坐标