您現在的位置:程序化交易>> 外匯現貨>> 仟家信等>> 仟家信公式>>正文內容

非常準的指標 趨勢拐點源碼[仟家信公式]

非常準的指標 趨勢拐點源碼:

VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
A:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);
B:ZIG(3,50/5)*100,colorwhite;
G:MA(B,2),coloryellow;
D:=CROSS(B,G)*1000,colorred;
W:=CROSS(G,B)*1000,colorblue;
E:=REF(INDEXC,1);
F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);
VAR10:=F AND F<8;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR13 AND VAR13<20;
MM:=A AND D AND VAR10 AND VAR14 ;
DRAWTEXT(W=1000,B*1.05,'拐下' ),COLOR00FF00;
DRAWTEXT(D=1000,B*1.05,'拐上'),colorred;

 

源碼解析:

VAR1賦值:最高價-最低價和最高價-昨收的絕對值的較大值和最低價-昨收的絕對值的較大值的25日累和
VAR2賦值:最高價-昨日最高價
VAR3賦值:昨日最低價-最低價
VAR4賦值:如果VAR2>0ANDVAR2>VAR3,返回VAR2,否則返回0的25日累和
VAR5賦值:如果VAR3>0ANDVAR3>VAR2,返回VAR3,否則返回0的25日累和
VAR6賦值:VAR4*100/VAR1
VAR7賦值:VAR5*100/VAR1
VAR8賦值:VAR7-VAR6的絕對值/(VAR7+VAR6)*100的15日簡單移動平均
VAR9賦值:(VAR8+15日前的VAR8)/2
A賦值:(VAR7>VAR6 AND VAR7>25 AND VAR6<25)
輸出B:收盤價50/5%的之字轉向*100,畫白色
輸出G:B的2日簡單移動平均,畫黃色
D賦值:B上穿G*1000,畫紅色
W賦值:G上穿B*1000,畫藍色
E賦值:昨收
F賦值:收盤價-E和0的較大值的3日[1日權重]移動平均/收盤價-E的絕對值的3日[1日權重]移動平均
VAR10賦值:F AND F<8
VAR11賦值:(收盤價-9日內最低價的最低值)/(9日內最高價的最高值-9日內最低價的最低值)*100
VAR12賦值:VAR11的3日[1日權重]移動平均
VAR13賦值:VAR12的3日[1日權重]移動平均
VAR14賦值:VAR13 AND VAR13<20
MM賦值:A AND D AND VAR10 AND VAR14
當滿足條件W=1000時,在B*1.05位置書寫文字,COLOR00FF00
當滿足條件D=1000時,在B*1.05位置書寫文字,畫紅色
 

 

如果以上指標公式不適用于您常用的行情軟件

或者您想改編成選股公式,以便快速選出某種形態個股的話,

可以聯系我們相關技術人員 QQ: 262069696  點擊在線交流進行 有償 改編!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  新疆18选7基本走势带坐标